Failed to fetch error message

I’m fairly new when it’s comes to Lido. I keep getting this error message “failed to fetch”. Can anyone explain this to me?


We’re sorry that you were inconvenienced.

Please check the network which your wallet is set up.
If you use Metamask, please check its connection to Etherium Mainnet for carrying out operations.

1 Like

Hey @therecycledpirate,

Thank you very much for submitting this issue!

It appears that there were issues with wallet-provided network service.

We made some adjustments to always retry failed requests when such requests fail and changed the error message to describe the issue. We will push an update soon.

Did error messages appear straight away? Or when you connected your wallet for example? Any chance you switched to another app before you saw these errors?

If it’s alright, please provide your:

  • Device
  • Browser
  • Wallet connected (eg Metamask / Argent via WalletConnect)

Thank you in advance!

1 Like

Hi, thank you for your quick reply. It is in Trustwallet’s DApps on a Google Pixel. It seems to load later, and then multiple notifications follow. I’m not a very advanced user to be honest. So I haven’t accessed it from my Meta.

Oh, thank you for the details — that would help greatly, tbh. Another thing I’ve noticed is, it seems like fonts haven’t loaded up correctly — I suppose there’s some network (i.e., mobile or wi-fi, not blockchain one) issue in play as well. Could you try from another network connection, if hadn’t already?

1 Like

I moved in the last month and therefor have used three different connections. I just switched to the neighbors and reloaded and received many “failed” notifications that it took up my full screen.

I’m trying to figure out how to use it in my Meta, but it just won’t connect. It does connect with Trust.

Got it, thank you! We’ll be looking into this and get back with any findings. If by any chance you’ll get through — ping us here, please.

1 Like

By the way, have you tried connecting from your default browser by choosing Trust or WalletConnect->Trust on when connecting a wallet?

1 Like

Yes, and it’s working but no rewards notifications. Did the same in my Meta browser. No notifications or rewards. Thank you, simple suggestion that is often looked over :+1:.

Tried it again in my Trust, four notifications “failed to fetch”, they disappeared to fast for me to screenshot.

You see, Lido rewards are simply balance updates - each day you will see slightly bigger amount of stETH in your wallet without new transactions for rewards.

We are actually currently working on a separate page on our website which will show daily rewards!


Thank you for explaining that. I’m teaching the basics to people that know even less than me to get the grassroots movement going on Curaçao Therefor I’m testing and learning as much as I can. Truly appreciate the effort from everyone.

Thank you :v:

1 Like

So, what’s the problem?
And the solution?