Problems swapping stETH for ETH

I staked ETH with Lido and now I am not able to swap stETH for ETH on Curve. I get the message „Gas estimation for this transaction failed, which means there’s a high probability that this transaction will fail if submitted”. How this could be solved?

1 Like

Try starting the process over again from the beginning.

I tried a couple of times but no results. Basically my stETH is blocked in my metamask wallet: I can see it but I can’t swap it for ETH on curve and I can’t deposit and stake it in gauge on curve. Moreover it seems that I don’t get any stalking rewards. I staked Ethereum with Lido around two days ago and now everything is frozen.

Hi @luciano - so you’re wanting to swap your stETH back to ETH?

Is it possible that the gas fees are too high when you tried? The network has been a bit congested the last few days.

If you’re still having issues with the above link- You can always try swapping on Uniswap v2 as well.

Keep us posted how things are going.

1 Like

Thanks for your answer. Everything is solved. Yes, the gas fees were high and I didn’t have enough ETH in my metamask wallet to cover them. Now they are lower and everything is going smoothly. Obviously, it was my mistake yesterday: rookie mistake. Sorry!!!


No worries!

Glad everything worked out - don’t be shy to come here and ask questions anytime.


Can someone give me all the steps I need to take to swap my steth in eth from my ledger
Its kinda hard because when I want to do it the ledger only gives the adress of my ethereum token and not of the lido steth. I cannot see it in my adresses
Dont want to make any mistakes

Ledger is currently updating their Paraswap app on Ledger Live to v5, which would resolve the issue of stETH not showing up in-app.

These steps should work to swap through Paraswap (not in-app):

  1. Head over to ParaSwap - Solving Liquidity for DeFi
  2. Connect your Ledger wallet directly.
  3. Swap the first box with stETH by importing it.
  4. Swap the box under it to ETH.
  5. Select “Unlock stETH”.
  6. You confirm that approval transaction (it will cost gas).
  7. Afterwards, once that transaction is done, you select “Swap”
  8. You confirm that transaction as well (it will cost gas), and wait for it to finalize.
1 Like


When will ledger be ready with resolving this?

Kind regards

We don’t have an ETA, but we are currently bugging them about it. Thanks for your patience!

Hi I followed your guidance for exchanging steth for eth on paraswap. When I click unlock steth it gives 2 options unlock permanently or unlock this time only. When I click unlock this time and approve it on my nano stick nothing happens? I’m scared to unlock permanently as this unlocks unlimited steth??


I believe this issue could be due to “smart contract data” or “blind signing” being disabled on your Ledger device. You should be able to change that through your settings.

That isn’t in my settings on my nano x?

I enabled blind signing in my eth app. Although I’m still having the same issue?


Is there any news about swapping steth to eth on paraswap?

You can use to perform the swap. Ledger still needs to update their Paraswap app on Ledger Live.

1 Like

Hi, I have tried to do the swap in paraswap but I am trying to swap Steth to USDT directly and have it transferred to my account. When I try to unlock STETH it asks for my approval but nothing is displayed in trezor so I cant approve anything. I have made sure I have gas fees (ETH) in my trezor as well so I dont know what is going on. I also tried via curve and it is not working either. Can someone please help?

Please make sure that your Trezor firmware is up to date. I’m not sure if it applies to Trezor devices, but for Ledger, users need to enable “blind signing” and “smart contract data” in the settings. You can also use to perform the swap, or use the FTX exchange to sell to USD.

My unlock stEth is grayed out? Please advise?

On January 28, 2023 I tried twice through paraswap to convert STETH to ETH, But now a few days have passed and it has not been done. Today, I registered this request through the, but it was not done. Please help me to solve my problem. thank you